Build log: 1.2.17

Thursday, Jul 21, 2016 - 10:20 PM (CDT)

--- drush dreditor-build: executing command ---
$ git clone --depth=50 --branch=1.2.17 git://github.com/unicorn-fail/dreditor.git .
Cloning into '.'...
Note: checking out 'b4369397ae4b4482a4d0ba1652296790130f2702'.

You are in 'detached HEAD' state. You can look around, make experimental
changes and commit them, and you can discard any commits you make in this
state without impacting any branches by performing another checkout.

If you want to create a new branch to retain commits you create, you may
do so (now or later) by using -b with the checkout command again. Example:

  git checkout -b 

--- drush dreditor-build: executing command ---
$ git checkout -qf b4369397ae4b4482a4d0ba1652296790130f2702
--- drush dreditor-build: executing command ---
$ node --version
v4.4.7
--- drush dreditor-build: executing command ---
$ npm --version
2.15.8
--- drush dreditor-build: executing command ---
$ npm install --color=always --no-optional
npm WARN package.json dreditor@1.2.17 No license field.
npm WARN deprecated lodash@2.4.2: lodash@<3.0.0 is no longer maintained. Upgrade to lodash@^3.0.0
npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated deflate-crc32-stream@0.1.2: module has been merged into crc32-stream
npm WARN deprecated graceful-fs@1.2.3: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use 'npm ls graceful-fs' to find it in the tree.
npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@1.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated graceful-fs@3.0.8: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use 'npm ls graceful-fs' to find it in the tree.
npm WARN deprecated lodash@2.1.0: lodash@<3.0.0 is no longer maintained. Upgrade to lodash@^4.0.0.
grunt-contrib-copy@0.5.0 node_modules/grunt-contrib-copy

grunt-exec@0.4.5 node_modules/grunt-exec

grunt-css2js@0.2.4 node_modules/grunt-css2js

grunt-contrib-concat@0.4.0 node_modules/grunt-contrib-concat
└── chalk@0.4.0 (ansi-styles@1.0.0, has-color@0.1.7, strip-ansi@0.1.1)

grunt-contrib-clean@0.5.0 node_modules/grunt-contrib-clean
└── rimraf@2.2.8

clean-css@2.0.8 node_modules/clean-css
└── commander@2.0.0

grunt-sed@0.1.1 node_modules/grunt-sed
└── replace@0.2.10 (colors@0.5.1, minimatch@0.2.14, nomnom@1.6.2)

load-grunt-tasks@0.4.0 node_modules/load-grunt-tasks
├── multimatch@0.1.0 (lodash@2.4.2, minimatch@0.2.14)
└── findup-sync@0.1.3 (lodash@2.4.2, glob@3.2.11)

grunt@0.4.2 node_modules/grunt
├── eventemitter2@0.4.14
├── which@1.0.9
├── dateformat@1.0.2-1.2.3
├── async@0.1.22
├── colors@0.6.2
├── getobject@0.1.0
├── lodash@0.9.2
├── rimraf@2.0.3
├── hooker@0.2.3
├── exit@0.1.2
├── coffee-script@1.3.3
├── nopt@1.0.10 (abbrev@1.0.9)
├── minimatch@0.2.14 (sigmund@1.0.1, lru-cache@2.7.3)
├── iconv-lite@0.2.11
├── underscore.string@2.2.1
├── glob@3.1.21 (inherits@1.0.2, graceful-fs@1.2.3)
├── findup-sync@0.1.3 (lodash@2.4.2, glob@3.2.11)
└── js-yaml@2.0.5 (esprima@1.0.4, argparse@0.1.16)

grunt-contrib-uglify@0.4.0 node_modules/grunt-contrib-uglify
├── chalk@0.4.0 (has-color@0.1.7, ansi-styles@1.0.0, strip-ansi@0.1.1)
├── maxmin@0.1.0 (pretty-bytes@0.1.2, gzip-size@0.1.1)
└── uglify-js@2.7.0 (async@0.2.10, uglify-to-browserify@1.0.2, source-map@0.5.6, yargs@3.10.0)

grunt-contrib-compress@0.9.1 node_modules/grunt-contrib-compress
├── prettysize@0.0.3
└── archiver@0.9.1 (buffer-crc32@0.2.5, lazystream@0.1.0, lodash@2.4.2, readable-stream@1.0.34, zip-stream@0.3.7, tar-stream@0.3.3, file-utils@0.1.5)

grunt-mozilla-addon-sdk@0.3.2 node_modules/grunt-mozilla-addon-sdk
├── q@0.9.7
├── mv@1.0.0 (rimraf@2.2.8, ncp@0.4.2, mkdirp@0.3.5)
├── request@2.27.0 (tunnel-agent@0.3.0, aws-sign@0.3.0, forever-agent@0.5.2, qs@0.6.6, oauth-sign@0.3.0, mime@1.2.11, cookie-jar@0.3.0, json-stringify-safe@5.0.1, node-uuid@1.4.7, http-signature@0.10.1, form-data@0.1.4, hawk@1.0.0)
└── tar.gz@0.1.1 (commander@1.1.1, tar@0.1.20, fstream@0.1.31)

grunt-contrib-jshint@0.10.0 node_modules/grunt-contrib-jshint
├── hooker@0.2.3
└── jshint@2.5.11 (underscore@1.6.0, strip-json-comments@1.0.4, exit@0.1.2, console-browserify@1.1.0, minimatch@1.0.0, shelljs@0.3.0, cli@0.6.6, htmlparser2@3.8.3)

grunt-contrib-less@0.11.0 node_modules/grunt-contrib-less
├── async@0.2.10
├── chalk@0.4.0 (ansi-styles@1.0.0, has-color@0.1.7, strip-ansi@0.1.1)
├── lodash@2.4.2
├── maxmin@0.1.0 (pretty-bytes@0.1.2, gzip-size@0.1.1)
└── less@1.7.5
--- drush dreditor-build: executing command ---
$ grunt --version
grunt-cli v0.1.13
grunt v0.4.2
--- drush dreditor-build: executing command ---
$ grunt install --no-optional
Running "mozilla-addon-sdk:release" (mozilla-addon-sdk) task
Downloading: https://ftp.mozilla.org/pub/mozilla.org/labs/jetpack/addon-sdk-1.16.tar.gz

Done, without errors.
--- drush dreditor-build: executing command ---
$ grunt build --no-optional
Running "clean:files" (clean) task

Running "less:files" (less) task
File build/dreditor.css created: 11.5 kB → 9.71 kB

Running "css2js:convert" (css2js) task
File "build/dreditor.css.js" created.

Running "jshint:package" (jshint) task
>> 1 file lint free.

Running "jshint:gruntfile" (jshint) task
>> 1 file lint free.

Running "jshint:js" (jshint) task
>> 26 files lint free.

Running "concat:build" (concat) task
File build/dreditor.js created.

Running "copy:chrome" (copy) task
Created 1 directories, copied 3 files

Running "copy:firefox" (copy) task
Created 2 directories, copied 4 files

Running "copy:safari" (copy) task
Copied 5 files

Running "sed:name" (sed) task
build/chrome/manifest.json
build/dreditor.safariextension/Info.plist
build/firefox/lib/main.js
build/firefox/package.json
build/update.plist

Running "sed:title" (sed) task
build/chrome/manifest.json
build/dreditor.safariextension/Info.plist
build/firefox/package.json

Running "sed:description" (sed) task
build/chrome/manifest.json
build/dreditor.safariextension/Info.plist
build/firefox/package.json

Running "sed:homepage" (sed) task
build/chrome/manifest.json
build/dreditor.safariextension/Info.plist
build/firefox/package.json
build/update.plist

Running "sed:author" (sed) task
build/chrome/manifest.json
build/dreditor.safariextension/Info.plist
build/firefox/package.json

Running "sed:icon" (sed) task
build/chrome/manifest.json
build/firefox/package.json

Running "sed:license" (sed) task
build/firefox/package.json

Running "sed:version" (sed) task
build/chrome/dreditor.js
build/chrome/manifest.json
build/dreditor.js
build/dreditor.safariextension/Info.plist
build/dreditor.safariextension/dreditor.js
build/firefox/data/dreditor.js
build/firefox/package.json
build/update.plist

Running "uglify:default" (uglify) task
File build/dreditor.js created: 99.16 kB → 65.75 kB

Running "compress:chrome" (compress) task
Created release/chrome/dreditor.zip (42376 bytes)

Running "mozilla-cfx-xpi:release" (mozilla-cfx-xpi) task
Creating dist dir '/tmp/drush_tmp_1469157630_579190fe2a63b/release/firefox'...
Creating xpi...
Generated XPI: /tmp/drush_tmp_1469157630_579190fe2a63b/release/firefox/dreditor.xpi

Running "exec:build_safari_ext" (exec) task
Created release/safari/dreditor.safariextension

Done, without errors.